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Neither the whole or any part of the information contained in, nor the product described in this document may be 
adapted or reproduced in any material form except with the prior written consent of Scale-Tron Inc. 

 

© 2023 Scale Tron Inc. 
 2113C St Regis 
 Dollard-des-Ormeaux, Québec 
 H9B 2M9 
 Canada 
 

All rights reserved 

Customer Responsibility: 

The customer in applying the product described in this document accepts that the product is a programmable 
electronic system which is inherently complex. In doing so, the customer therefore undertakes the responsibility to 
ensure that the product is properly installed, commissioned, operated, and maintained by competent and qualified 
personnel, trained in accordance with any instructions or safety precautions made available, or through proper 
engineering practices, and to thoroughly verify the use of the product in each particular application. 

Errors in documentation: 

The product described in this documentation is subject to continuous development and improvement.  All 
information of a technical nature and particulars of the product and its use including the information and 
particulars contained in this documentation are given in good faith by Scale-Tron Inc. 

This manual is intended only to assist the user in the installation, use, and operation of the product, and therefore 
Scale-Tron Inc. shall not be liable for any loss or damage whatsoever from the use of the information in, or any 
error in, or omission from this manual. 
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Introduction 
 
 
Plant Studio, Link Application (BatchLink), allows you to control the production of concrete and 
manage concrete quality. BatchLink has following three main functions: 
 
1. Concrete production management. This function is accessible from the menu "Order Entry". 
 
2. Concrete production monitoring and control. This function is accessible from the menu "View"   
"Plant Ctrl". 
 
3. Report functions. All the reports are accessible from the menu "Report". 
  
There are other essential utilities which are designed to support the above three functions.  
They are: 
(1) Mix design functions, which are accessible from the menu "View" "Formula". 
(2) Material receipt, which is accessible from menu "View"  "Receivership". 
(3) Report designer and HMI (human machine interface) designer, which are accessible from the 
menu "Tools" "Report Design" and "HMI Design".   
 
 
Should you need assistance at anytime please contact us as follows: 
 
E mail: service@scaletron.com 
 
Tel : +1 514-940-0337 
 
 
  

mailto:service@scaletron.com
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Menus 
 
Menu File 
This menu has all the commonly used database maintenance commands. 
 
1. Menu "Renew": Empty and re-initialize the data table. This function is only available when a 
table editor or a report selector is active. 
 
2. Menu "Close": Close the currently active data table. 
 
3. Menu "Save as CSV File": Saves current active data table to a CSV file. MS Office Excel or 
Access can be used to read these CSV files. This function is only available when a table editor or 
a report selector is active. "How to Print the Mix Design" section shows an instance of how to use 
this function. 
 
4. Menu "Backup Database": Save all data to default backup folder or any pre-determined folder. 
"How to Backup All Saved reports" has more information on this function. 
 
5. Menu "Import Text File": Imports a text file into the database. The text file can be a batch report 
saved on the PLC memory card or a CSV file modified by MS Office Excel or Access. "How to 
use PLC Memory Card" section has more information on how to read a PLC memory card file. 
"How to Edit Mix Design outside the BatchLink Application" has more info on how to read CSV 
files. 
 
6. Menu "Import Database File": Import backup database file back to the system.  "How to Import 
Report from Previous Backup / Archived Database" section has more information on how to use 
this function. 
 
7. Menu "Page Setup": Setup reports for a specific printer. 
 
8. Menu "Print to Clipboard": Only available when a report is active. Send a report to Windows 
system clipboard. Windows System clipboard can be used to paste reports into other applications.  
 
9. Menu "Print": Only available when a report is active. Send report to a specific printer.  
 
10. Menu "Exit": Close BatchLink application 
 
 
Menu Edit 
This menu is only available when a data table is active and has all the commonly used table edit 
commands. For cell edit, there are Copy, Paste and Delete commands. For row edit, there are 
Delete Selected Row(s), Copy Row commands. For column edit, there are Rename Selected 
Column, Hide/Show Selected Column and set a column as leader command. For the table edit, 
there are Find and Property commands.     
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Menu View 
This menu has all the concrete production monitoring and control utilities.  
 
1. Menu "Plant Ctrl" will open a new window allowing the operator to monitor and control the 
production process. A graphic plant layout will display the main batching screen. Control buttons 
will allow the user to manually control production. 
 
2. Menu "Formula" has several sub menus such as "Target", "Ingredient price" and "Formula 
price". Some options related to mix design editing are also accessible under menu "Formula". 
The user can choose to show the water cement ratio during water target editing, or to show the 
admixture to 100 units of cement ratio during admixture target editing, or display ingredient target 
in alterative units during any ingredient target editing.  
(a) "Target" is for mix design modifications. Any modification made from this menu will be 
downloaded to the BatchTron; however, any modification made directly from BatchTron will not 
be uploaded automatically. The user can manually compare, uploaded and download mix designs 
between the BatchTron and the computer. "How to Edit Mix Design" section has more information 
on this function.  
(b) "Ingredient Price" is the sale price and cost price editor.  
(c) "Formula Price" is for the mix design price editor. The ingredient’s sale and cost price can be 
used as reference during mix design price editing. "Procedure to Edit Mix Design Price" has more 
info on how to use this function.  
 
3. Menu "Sequence" has two sub menus: "Batching Sequence" and "Mixing Sequence". 
- "Batching Sequence" is the sequence in which the ingredients are started. 
- “Mixing Sequence" " is the sequence in which ingredients are discharged to the mixer or truck. 
 
4. Menu "Inventory Receivership" is for material receipts, quantity editing and ingredient on hand 
adjustment.  
 
5. Menu "Batch Ctrl Setting" is for batching and mixing parameter editing. Please check "How to 
Edit Batching and Mixing Control Parameters" section for more info. 
 
6.Menu "Order Entry" has all Concrete production management utilities. 
 
7. Menu "Report" has all the report utilities. 
 
8. Menu "PLC" has all PLC communication commands. 
 
(Please check "How to Edit Mix Design" and "How to Edit Batching and Mixing Control 
Parameters" sections for more information on how to use "Download to PLC", "Upload from PLC" 
and "Verify with PLC". Please check "How to Use PLC Memory Card" for more information on 
how to use "Check Memory Card Report")  
 
9. Menu "Tools" has all the setup commands. 
 
10. Menu "Window" has the all commonly used window arrangement commands. 
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Tools Bar and Status Bar 

On top of the window is a menu. Below the menu is the tool bar button.  
 
Frequently used menu items have tool bar buttons. The Toolbar button’s function will be displayed 
when you hover your cursor over it. 
 
There is status bar at bottom of the window. It shows if any data table is active. It also shows 
current connected PLC information. 
  
 
How to Edit Data in BatchLink 
All data is displayed as a table. The mix design is shown here as an example: 
 

 
 
1. Adding a new row: A new row can be added by modifying any cell in the last row of the table.  
 
2. Column Sort: (a) Highlight the column header, (b) Select the menu "File" -> "Sort" -> "Sort 
(AZ)" or "Sort (ZA), or from sort buttons in the tool bar or from the pop-up menu (right click mouse 
then pick). 
 
3. Delete a row: (a) Highlight the row from the row selector (far left tab on each row). (b) right 
click the mouse then delete.  
 
4. Copy / Paste a row: (a) Highlight a row (b) Initialize the "Copy Row" functions from either the 
"Edit" menu or from the pop-up menu (right click the mouse then pick). (c) Select another row and 
initialize the "Paste Row" function from either the "Edit" menu or from the pop-up menu (right click 
the mouse then pick). 
 
5. Customizing a table: table size, table display, column width, row height and column header 
captions can all be customized. Any column can be ‘selected’ and ‘hidden’ as required. All the 
dimension customization (size, position, width, height) can be adjusted by the mouse, clicking 
and dragging on the table’s edge or on the boundary of the row/column.  All other customization 
can be done from the "Edit" menu or from the pop-up menu (right click the mouse first). Some 
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customization functions are not available if "Disable Manager's Function" is checked. The 
"Disable Manager's Function" menu is under the menu "Tools" -> "Basic Setting". A password will 
be required to uncheck. Unchecking "Disable Manager's Function" will make all functions 
available. The default password is 123. See Security Principle section for detail. 
 
6. Table info: Current row number and total row number is shown in the status bar.  
 
How to Edit a Mix Design (Formula) 
1. A mix design can be edited from the computer. Any edited mix design will automatically 
download from the computer to the BatchTron. 
Note you must ensure the PC is connected to the BatchTron when using this function 
 
There are "Download to PLC", "Upload from PLC", "and "Verify with PLC" commands under the 
menu "PLC". This menu will be active when the mix design edit window is active. These 
commands are designed for synchronizing the mix design between computer and BatchTron. 
 
2. There are same configurations that need to be setup before editing the mix design from the 
computer side. These configurations will define the ingredient unit, quantity, decimal place, save 
size, mix design name, save size, mix design save area, total number of mix designs saved in the 
BatchTron. The mix design must be uploaded again if you change any of these setup parameters.  
If this is not done "Verify with PLC" will show “failed”. All setup parameters are accessible under 
menu "Tools".    
 

3. Click tool bar icon  or click menu "View" -> "Formula" -> "Target" to create a mix design 
(formula) edit from the computer. This menu is not available if “formula price” edit window is open. 
Mix design (formula) ingredient weight or volume should be for one cubic unit. 
 

 
 
4. Select one row in the mix design editor table, change the batch size on top of the table, click 
"Show" button, the target for a particular batch size will be shown, the aggregate and water target 
will be compensated by the current aggregate moisture value.    
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How to Print the Mix Design 
The mix design table may be wider than paper used in your printer. It is therefore recommended 
that if printing of mix designs is required, you save this file in an appropriate location and print 
using MS office, Excel or Access. 
   

1. Open Mix Design by clicking tool bar icon  or click menu "View"->"Formula"->"Target" 
 
2. Save the mix design to file by clicking menu "File"->"Save as CSV File" 
 
3. Using Excel to open this file and print the mix design provides many additional page formatting 
tools. 
 
How to Edit Mix Design outside the BatchLink Application 
The purpose of "Import CSV File" is to allow the user to edit the mix design (or other information) 
using Excel or Access and import the edited results into BatchLink. 
 
The procedure is as follows: 
 
1. Export the mix design to a CSV file by menu "File" -> "Save as CSV File" 
 
2. Modify the CSV file using Excel or Access. Please do not change the table structure and column 
name during editing. 
 
3. Import the file back into the application.     
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How to Share Data with Other Applications 
The batch or load data can be shared with other applications. There are two ways to share the 
data.  
Option 1, manually save the data to a CSV file after production is complete so other applications 
are able to read this file.  
Option 2, Use BatchLink to automatically update the CSV file batch by batch and other 
applications can then read the file to get the new production information batch by batch. 
 
Procedure for Option 1: 
1. Click menu "Data" -> "Batch Report Data" or "Load Report Data" depending on which 
information you would like to share.  
2. Select the start and end date/time of the production. 
3. All data regarding concrete target or actual values batched cannot be edited. Column names 
can be modified to match other application's column or field preference. See section “Menu Edit” 
for details on how to do this. The information can be sorted by any column, allowing the data to 
be sorted according to other application's preference. Edited names and sort selection will be 
saved by this application.     
4. Select a group of rows by holding the “Shift” key while selecting the first row and last row; or 
pick up several rows by holding “Alt” key while selecting the rows. If you are sharing all production 
information you can skip this step. 
5. Click menu "File" -> "Save as CSV File". Select a drive and folder to save the file to. 
 
Procedure for Option 2: 
1. Make sure no new reports are pending and no production is running. 
2. Follow step one and two from option 1 above.  
3. Make sure the date/time column is sorted from old to new, re-sort the column if necessary. 
4. Click menu "File" -> "Save as CSV File". Select the folder: \BatchLink Support Files\; the file 
name must be Recording.CSV. 
5. Make sure the menu "Tools" -> "Basic Settings" -> "Maintain Batch Data as CSV" is checked.  
6. Close BatchLink then Restart the BatchLink.  
7. BatchLink will update the Recording.CSV file after receiving every batch report. Other 
applications can read the Recording.CSV file periodically to get the new production information. 
The batching history is stored in the “Recording.CSV file”. The historical data can be saved as 
per the specified time entered in menu "Tools" -> "Basic Settings" -> "Report Paging Settings".    
 
Note BatchLink cannot verify if any reports are missing in the Recording.CSV file when compared 
to the database in the BatchTron.  
 
Procedure to Edit Mix Design Price 
The delivery ticket can calculate and show the ingredient cost and concrete sale price. The 
cost/price calculation is based on the mix design price.  
 
The Material Usage and Production report can calculate and show the cost by both mix design 
and actual ingredient values. The cost by mix design is calculated by individual batches mix 
design price (menu View -> Formula Price) and batch size. All batches are added together to get 
the cost by mix design value. The cost by ingredient is calculated by total ingredient usage and 
ingredient cost price. The ingredient cost price value is calculated from the first row in the menu 
View -> Formula Price -> Cost Price. The report value for cost by mix design will change if the 
formula price is changed after batching. The report value for ingredient will also change any time 
the first low value in the ingredient cost price is changed. 
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The Production Report Summary in Batch reports also shows the cost for each batch. This cost 
is based on formula price. This cost will not change if the formula price is changed after the load 
is complete. 
 
Procedure to edit the mix design price.  
(a) Edit mix design by menu "View" -> "Formula" -> "Target".  
 
(b) Edit ingredient cost price and sale price by menu "View" -> "Formula" -> "Ingredient Price". 
This window will be not available while the mix design price editing window is open. 
 
(c) Mix design (Formula) price can only be edited when both mix design edit window and 
ingredient price edit windows are closed.  
 
(d) Edit mix design price by menu "View" -> "Formula" -> "Formula Price". In "Batch Formula Price 
Editor" window, each mix design has a price, which is editable. This price is for one cubic unit. 
There are ingredient cost prices and sale prices available as a reference. These ingredient prices 
are only changeable by selecting different ingredient price names. The cost or sale price will be 
refreshed by clicking the update button after the cost or sale price has been changed.  
 
(e) A plant may have multiple material suppliers bringing in the same material. For this reason, 
the Ingredient Cost Price Editor table can have multiple rows. However, only the first row will be 
used by the Material Usage and Production report. The “price name” can be changed. The price 
name column sort function will arrange the row in alphabetical order.      
 

How to Calculate Concrete Yield 

The mix design editor table can display the concrete yield. There are three ways to calculate the 
yield. Some calculation parameter must be entered from menu "View" -> "Concrete Yield" -> 
"Calculation Parameter". Calculation method can be selected by check "by Unit Weight" or "by 
Specific Gravity" or "by Relative Specific Gravity".  
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If sub menu "by Unit Weight" is checked, then Concrete Unit Weight must be entered in "Concrete 
Yield Calculation Parameter Editor" table. All other columns can be left as zero. If the sub menu 
"by Specific Gravity" is checked, specific gravity (density) must be entered under all solid 
ingredient and water in "Concrete Yield Calculation Parameter Editor" table. All other columns 
can be left as zero. If sub menu "by Relative Specific Gravity" is checked, relative specific gravity 
(relative density) must be entered under all solid ingredient and water in "Concrete Yield 
Calculation Parameter Editor" table. All other column can be left as zero. 
If no calculation method is checked, BatchLink will not calculate yield. 
 
The simplest way to calculate the yield is to enter the Concrete Unit Weight. The unit should be 
lbs/C.Y., if units used are pounds or Kg/C.M. , if units used are kilograms. In cases were 0.5 cubic 
foot containers are used to measure fresh concrete. Assuming the 0.5 C.F. container net weight 
is 72.3 lb, then (27 * 2 * 72.3) 3904.2 lb should be entered under the column ‘Concrete Unit 
Weight’ 
   
How to Get Reports 
BatchLink produces several reports, the most common being batch reports, load (truck) reports, 
material usage reports, production reports and inventory reports. Batch and load reports can have 
different formats for different plants. Load report are typically used for ready mix applications. 
 
1 Procedure to open or print a report 
 

 
 
(a) Click menu "Report" -> sub menu "Batch". 
(b) Select begin date / time, end date / time etc.  
(c) Click "Show Report" button to open the report. 
(d) Click tool bar printer icon to print the report.  
 
2 Change how many reports are opened at the same time. 
Including several thousand reports into report selector table may take time and use excessive 
computer memory. For this reason reports from several months ago may not need to be opened.  
BatchLink has a function to define how may months of the report need to be included in the report 
selector table and allow to select a time period before opening the report selector. This function 
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can be accessed from menu "Tool" -> sub menu "Basic Settings" -> "Report Paging Settings". In 
"Report Paging Setting" dialogue window, if 1 is entered as report period, only one month plus 
the current month report will be included in the report selector table. If “Yes” is entered this allows 
you to modify report interval, and a date period dialogue window will be open before opening the 
report selector table. 
 
Inventory Reports 
Inventory (on-hand) reports rely on the batch report value and material received value. 
Receivership value must start with a date / time, prior to the date / time of first batch report. If this 
initial date / time is not known, a 1 must be entered under the column of a specific ingredient 
name as received amount before first batch begins. Inside receivership table, date and time 
column can be left empty, column with ingredient name (receivership column) is used to enter 
amount received and the date / time, on hand column is for inventory adjustments. Receivership 
column and on hand column cannot have the same value (one column must be empty or set as 
zero). If on hand column is empty and receivership column has a value, after clicking the "Update" 
button, on hand column will be populated to show the entered amount of material available. If on 
hand column is not empty and receivership column is empty, after clicking the "Update" button, 
receivership column will be populated to show how much material is supposedly received.           
         
After editing the receivership table, the inventory report can be used to check how much material 
is on-hand at any time. The on-hand amount will have the same accuracy as the scale, it will not 
accumulate the material for the batch if it is aborted before a report is entered. For this reason, 
the inventory report may show incorrect amounts after several months production. If this happens, 
the receivership table can be edited by entering a new date, time and a new on hand amount to 
adjust the inventory report. This on hand amount can be positive or negative to increase or 
decrease the amount reported by inventory report 
 
 
How to Start Concrete Production from the Computer (PC) 
There are two ways to start production from the PC side. The first method is used for single batch 
or single load production. This method is also the simplest approach. It only needs the Load Entry 
Table.  
 
1. Starting Single load production using the Load Entry Table Only.  
(a) Prepare the BatchTron.  
From the Touchscreen on the BatchTron ensure the “Demand Enable” button is blue and 
enable the “Truck in Place” button. 
(b) On the PC Click the menu "Order Entry" -> "Load Entry" to open Load Entry editor. 
(c) Add a new row or select an existing row to modify it. 
(d) Enter Formula (Mix Design) number by clicking on the down arrow button on the right side of 
the Formula Number cell, or by pressing the enter key when the Formula number cell is 
highlighted. The predefined Formula (Mix Design) table will open to allow the selection of a 
formula. Using the up and down arrow keys on the keyboard or using the scrolling bar with the 
mouse select the desired row from the Formula table. Press the enter key or double click on the 
selected row to select a formula and close the Formula table. Formula type and Formula usage 
will be updated at the same time the Formula number is updated; however, these two cells can 
be independently modified if required after you update the Formula number. 
(e) Enter a load size by clicking on the down arrow button on the right side of the Load size cell, 
or by pressing the enter key when the Load size cell is highlighted. A digital value editor will open. 
Use the up and down keys to adjust the value, or type in a new value, or by clicking on the down 
arrow button on either side of the editor to modify the value. Pressing the enter key to finish the 
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value editing or Esc key to abort the editing. 
(f) Update the Load entry table by clicking the Update button. 
(g) Highlight the modified row in the Load entry table (Click the row selector from the far left of the 
table).   
(h) Click the menu "PLC" -> "Start Load" to start the load.  
(i) The menu "PLC" -> "Start Load" Or click the Start Load button on the toolbar will be grayed out 
if the BatchTron is not ready for a new load. Sometimes the BatchTron may hang during the 
production due to external issues identified on the plant such as a gate which is still open. In this 
case, if the production cannot start, the Abort button must be pressed on the BatchTron control 
panels touch screen to enable the "Start Load" submenu. 
  
The Formula Number and Load Size is the minimum requirement before starting production. All 
other cells are for the report function, they can be left blank. Any modification on these cells will 
be sent to the Load Report accordingly. 
 
For ready mix, all information pertaining to the mixer truck can be entered in the Truck/Driver 
submenu.  
 
All information pertaining to the customer or casting bed position can be entered in the Customer 
submenu.  
 
2. Starting multi Load Production using Load Entry, Order Entry and Job Entry--Systematically. 
When repeat batching for continuous production is required the following sequence should be 
used. It is assumed all these loads will share some common information such as the formula 
information, customer information, etc. In this case, an Order Entry can be defined before 
designing the Load Entry. Similarly, a Job Entry can be created before modifying the Order Entry.  
 
Getting Cumulative Order Totals 
The load report can show cumulative order totals. The value will be identified by the Load 
Information (name or ID) plus customer name. If the Load Information (name or ID) is not 
assigned,  then only the customer’s name will be used. 
 
The calculation without any taxes is: 
sum of [load size] x [Mix design price] 
 
This value and a correct tax rate together can be used to get the cumulative price for the order or 
customer. 
 
If a customer only places 1 order, then the Load Information (name or ID) in the load entry table 
can be left empty. However, if same customer places multiple orders the Load Info (name or ID) 
in load entry table must be populated with different order name or order ID to identity the totals 
for each order. 
 
The split ticket columns in the load entry table are used for special items such as hand added 
materials like fibers or special manually added admixtures. 
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How to Start Concrete Production from the Computer (PC) for Multiple loads 
All the loads in a particular order can be started if the Order Size in the Load Entry is populated. 
To enable this function on the BatchTron select “Enable Order Size” on the Demand page. The 
BatchTron will start another new load as soon as the last batch is complete. The operator only 
needs to confirm that the truck in place for each load. 
 
Editing Batching and Mixing Control Parameters 
1. All batching and mixing control parameter can be edited from the computer. Editing any 
parameter will automatically be downloaded from computer to the BatchTron if the computer is 
connected to the BatchTron.   
 
2. Procedure to edit or check any control parameter 

 
 
The Operational group has the Aggregate bin moisture value, using the moisture probe will 
automatically propagate this value, if no probe is used/connected then you can manually enter a 
value. The Tolerance group has all ingredient's tolerance parameters, for example the tolerance 
amount to trigger an alarm.  
The Control group has all the general control parameters, for example, cement weigh hopper 
vibrator or airation equipment on/off status. Moisture probe group has parameter for the probe 
assignment and filter. Plant setup group has plant configuration parameter, for example, select 
cement weigh hopper has a fully closed limit switch.  
 
Each parameter has a full description to aid the operator when editing. 
 
(a) All control parameters are grouped by function. There are operational groups, tolerance 
groups, control groups, scale or liquid meter groups, moisture probe groups and plant setup 
groups. All groups are accessible through menu "View" -> "Ctl Parameter Group Selection". Each 
group has several sub groups. Each page has several parameters which are all related to each 
other. 
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(b) Select one group from the top of the "Control Parameter Page / Group Edit and Selection" 
window. Select one row to highlight one page. Click the "Show" button from the top to view the 
page. 
 
(c) Edit the value for one or more parameter and click "Update" to save the change.  
 
3. There are "Download to PLC", "Upload from PLC" and "Verify with PLC" commands under 
menu "PLC". This menu will be active when the parameter edit window is active. These 
commands are designed for synchronization of the parameters between the computer and 
BatchTron. 
 
All control parameters defined in the BatchTron can be added and modified from the BatchLink 
application.  
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Backup, Delete and Import Reports  
The records in the database will accumulate, depending on how many batches you make per day, 
the report opening procedure will take longer as reports accumulate. You can speed up this 
procedure by backing up historical reports to another folder and delete or renew all the reports. 
This "Backup" will also provide a backup should the local computer fail for any reason. The 
"Renew" will check your report saving file's integrity and improve the safety on the report saving. 
You can use menu "File" -> "Import Database Files" to get reports from a backup.  
 
Scheduled Reports, Backup and Archive 
The BatchLink can automatically backup all saved reports and all the database files to a sub folder 
inside the default backup folder. The sub folders name is the scheduled day (day-month-year). 
BatchLink can also automatically empty the report database after a scheduled backup. This 
second automatic action is called Archive. The schedule for the archive should be longer than or 
equal to the schedule for the backup. Archive only deletes reports from the database not mix 
design etc. You must adjust the inventory from menu "View" -> "Receivership" to compensate the 
material usage released by the deleted report after archiving.  
 
You can enable/disable scheduled backup or archive functions, change the schedules, check the 
next due date and verify the success or failure of the backup / archive using the following 
procedure: 
 
(a) Click the menu "Tools" -> "Schedules".  
 
(b) Select backup or archive method. The function for each selection is as follows:  
Disable will stop the backup / archive. Remind me will display reminder message only  
Auto schedule will run backup /archive on each due date. 
 
(c) Select different backup or archive schedule. The due date for each selection is as follows: 
Weekly, Monthly, Quarterly. Bi annual will be July 1st and January 1st Yearly will be January 1st  
BatchLink will run backup / archive at the first instant on the due day.   
 
(d) Check next backup or archive due date. 
 
(e) Check previous backup or archive running result (success or fail).  
 
 
Backup All Saved Reports 
In the "File" menu, click submenu "Backup Database Files". All databases will be copied to the 
default folder; or any preferred folder. It is highly recommended that the backup folder is on a 
USB drive or external hard drive. The backup folder should be named by year, month, date. There 
is a backup note file which contains the backup date and time. This file will be automatically saved 
in the backup folder. Do not change the backup file’s name. The BatchLink program will check 
the file name before importing to the database.   
 
Importing Reports from a Previous Backup / Archived Database 
If you permanently need to access a previously archived report, you can re-import reports back 
to the system.        
 
(a) Click menu "File" -> "Import Database Files". 
 
(b) Select the database file: RECORDINGV2000.MDB. 
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Remember, the backup file should use its original name. 
You must adjust the inventory from menu "View" -> "Receivership" to compensate the material 
usage accumulated in the imported report after importing archival report. 
 
 
Opening a Report from a Previous Backup / Archived Database 
If you only need to reference the previous backup report occasionaly, you can open it as archived 
reports from the folder where you have saved the backup reports files.        
 
The archive reports file open procedure is as the following: 
(a) Click menu "Report" -> "Archival Report". 
 
(b) Select the database file: RECORDINGV2000.MDB. 
 
Remember, the backup file should use its original name. 
 
Using a PLC Memory Card 
Batch reports are saved into PLC memory card of your BatchTron. This is a more secure backup 
compared with computer hard drive. Millions of batches can be saved on the card. There are two 
ways to access these reports.  
 
1. From menu "File" -> "Import Text File" -> "Import PLC Memory Card". 
(a) Unplug the PLC memory card from the PLC in your BatchTron and plug it into a memory card 
reader. Make sure there is no production in progress or pending before unplugging the card. 
 
(b) Copy / paste the report files from PLC memory card to a temporary folder on the computer. 
Plug the memory card back into the PLC on your BatchTron. All batch reports are saved monthly 
on the card. All report files have the same name convention of YY-MM. Here YY is two digits for 
year, MM is two digits for month.  
 
(c) Use menu "File" -> "Import Text File" -> "Import PLC Memory Card" to select the reports need 
to be imported. The user can select either import all reports or only the unread reports. 
 
2. Direct from the BatchTron PLC. 
(a) Ensure no production is in progress or pending. This method while secure is fairly slow so it 
is best to do this after batching is completed for the day.   
 
(b) Use menu "PLC" -> "Check Memory Card" to show PLC Memory Card Info Display and File 
Selection window. This window shows all monthly saved batch report files recorded on the card. 
The top row shows the information of the card. Other rows are report files. One row per month. 
Each row shows how many repors have been recorded in the file and other useful information. 
 
(c) Select the file you wish to import and click the OK button to continue importing the report. The 
user can select either import all reports or only the unread reports. 
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Display Production Data as Trend Graph 
BatchLink Studio - Plant Historian application can display any production data as graph. The mixer 
moisture probe reading, slump meter reading, mixer temperature and free water in the aggregate 
are some examples of data which can be added to the data graph. BatchLink will record this data. 
The Plant Historian application will display the recorded data as a trend graph. 
 
1 Procedure to setup data for recording 
(a) Using menu "Tools" -> "HMI Design" -> "Plant Historian Settings" to setup the recording 
function. 
 
(b) Using menu "Tools" -> "HMI Design" -> "Plant Historian Address Setting" to add or remove 
data you would like to record. 
 
2 How to show the trend graph 
Run Plant Historian to display the data as a graph. Plan Historian application has all the settings 
built in to control how the graph is displayed. Automatically refresh the graph as new data 
recorded by BatchLink; Refresh interval, Data display color etc. 
 
Security 
There are total of six security clearance levels for special operational functions.  
Level 1 Modify mix designs.  
Level 2 Start a load from load entry.  
Level 3 Modify receivership data.  
Level 4 Import data or delete data.  
Level 5 Modify the control parameters.  
 
Managers can assign passwords to each security level. The procedure is as follows: 
(a) Uncheck "Disable Manager's Function" from menu "Tool" -> "Basic Setting". 
(b) Select "Change Manager or Operator Password" from menu "Tool" -> "Basic Setting". 
(c) Enter managers password. Modify password for each security level. or allow all operators to 
use the default security level. The default password for each level is 1 to 5. The default security 
level for all operators is 5. 
 
If an in-correct password is entered you will only be able to view data. 
    
If "Disable Manager's function" is unchecked, the System will treat the current operator as the 
manager, making all operational functions available without the need of any password.  
"Disable Manager's function" must be checked to enable the security principle. 
 
Manager password can be modified from menu "Tools" -> "Basic Settings" -> "Password" -> 
"Change manager or Operator Password". The default password is 123.  
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